<bgdev />free

Вход Регистрация

Гама спектрометър
4

0 1 2 3 4 5 6 7
#16761 (ツ) |
Създадено на 16:30, видяно: 53 пъти.
Дон Реба

а единиците каквиса сцинт/сек?

Да.

#16767 (ツ) johnfound
Създадено на 17:28, видяно: 40 пъти.

Всъщност какво точно се мери? Амплитудата на импулсите ли?

Ако е така – малката амплитуда на изхода на АЦП-то може да означава просто бавно АЦП или голямо закъснение на пускането му – например поради закъснение на прекъсването или аналоговата част.

Тогава ще мери импулса на спада. А импулсите, ако разбирам правилно са доста къси всъщност.

#16768 (ツ) Дон Реба
Създадено на 17:59, видяно: 35 пъти.
johnfound

Всъщност какво точно се мери? Амплитудата на импулсите ли?

Ако е така – малката амплитуда на изхода на АЦП-то може да означава просто бавно АЦП или голямо закъснение на пускането му – например поради закъснение на прекъсването или аналоговата част.

Тогава ще мери импулса на спада. А импулсите, ако разбирам правилно са доста къси всъщност.

ами те ацепетата имат един капацитет, дето се зарежда за кратко време (апертура) и след това преобразуването става колкото искаш бавно. чертата каза че неговия има удължител. аз още си настройвам схемата

#16769 (ツ) Дон Реба
Създадено на 18:02, видяно: 32 пъти.

дееа :) гледам, импулса не се връща до нула , остава леко надигната основата примерно 50 миливолта цъкнах осцилоскопа да видя кога се връща в норма, и видях че е след около 2 милисекунди брех, почвам начи да търся някви дълбоки дефекти, дали процесора сивдига консумацията и нещо пад по жиците... оказа се синия диод дето ми индицира че има сцинтилация, просмуква се през защитите и осветява сензора :)

#16770 (ツ) johnfound
Последно редактирано на 18:16 от johnfound, видяно: 28 пъти.
Дон Реба

дееа :) гледам, импулса не се връща до нула , остава леко надигната основата примерно 50 миливолта цъкнах осцилоскопа да видя кога се връща в норма, и видях че е след около 2 милисекунди брех, почвам начи да търся някви дълбоки дефекти, дали процесора сивдига консумацията и нещо пад по жиците... оказа се синия диод дето ми индицира че има сцинтилация, просмуква се през защитите и осветява сензора :)

Това може да е и послесветенето на сцинтилатора – това е нормално. Не всъщност не може.

https://upload.wikimedia.org/wikipedia/commons/3/33/%D0%A1%D1%86%D0%B8%D0%BD%D1%82%D0%B8%D0%BB%D0%BB%D1%8F%D1%86%D0%B8%D1%8F.png

А схемата sample/hold на входа на АЦП-то може и да не може да отследи бързо променлив сигнал. Това ѝ е параметър – има бързи, има и бавни. Трябва да провериш в спецификацията.

#16771 (ツ) Дон Реба
Създадено на 18:18, видяно: 22 пъти.

диода е бе, спрях го , оправи се

#16774 (ツ) johnfound
Последно редактирано на 18:50 от johnfound, видяно: 16 пъти.
Дон Реба

диода е бе, спрях го , оправи се

Да бе - виж че се коригирах. Но това за S/H схемата си важи. При толкова резки нараствания, ако искаш да хващаш амплитудата ще ти трябват реално бързи схеми пред АЦП-то.

По този повод – имаш ли някакъв буфер между фотодатчика и входа на АЦП-то? Защото кондензатора, който е в S/H схемата има нужда от голям ток, за да се презарежда бързо. А фотодатчика ти е 100% доста високоомен.

Повторител с бърз ОУ може да се окаже добра идея.

#16776 (ツ) Дон Реба
Създадено на 19:06, видяно: 10 пъти.

кондензатора на с/х схемата е само 4 пикофарада :) в пидиефасе кълнат че можеш да семплираш и през 5к резистор аз все пак надушвам някакъв проблем със семплирането, ама ще видим утре. със същия процесор съм семплирал 100 килохерца сигнал за рфид, и бачкаше много добре, тука обаче нещо не ми харесва, някои семпли са 0, това е нередно, защото самото задействане на семплирането е по амплитуда, все нещо трябва да има.

0 1 2 3 4 5 6 7

Гама спектрометър
4

AsmBB v2.9 (check-in: 072c21edcbadbc51); SQLite v3.31.1 (check-in: 3bfa9cc97da10598);
©2016..2020 John Found; Licensed under EUPL. Powered by Assembly language Created with Fresh IDE